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Preface
Copyright Notice

Copyright ©2020

Nanjing DECOWELLAutomation Co., Ltd.Copyright, all rights reserved. Without the written

permission of our company, no unit or individual may excerpt or copy part or all of the

contents of this document without authorization, and may not disseminate it in any form.

are trademarks of our company. Other

registered trademarks appearing in this document are owned by their respective owners.

Due to product version upgrades or other reasons, the contents of this document are subject

to periodic updates. Unless otherwise agreed, this document is for reference only, and all

statements, information, and recommendations contained herein do not constitute any

express or implied warranty.

Scope of this document

This document is applicable to FS Series Remote IO system

Introduction

This manual mainly introduces FS technical specifications, installation, and commissioning
of the series of remote I/O modules. The main contents include:

 System Overview: Provides an introduction to the FS Series remote I/O modules,

including ordering information, product composition, system architecture, as well as

transportation and storage environment.

 Product Description: Details the technical specifications of the FS Series remote I/O

modules.

 Installation and Removal Guide: Describes how to install and remove the FS Series

remote I/O modules.

 Mechanical and Electrical Drawings: Includes dimensional drawings and electrical wiring

diagrams of the FS Series remote I/O modules.

 User Guide: Demonstrates how the FS Series remote I/O modules communicate and

connect with various mainstream PLCs through practical examples.

Precautions



FS Series Remote IO User Manual

6

This document describes in detail the WELL-LINK FS usage of the series remote I/O

modules is for people with certain engineering experience. Nanjing DECOWELL is not

responsible for any consequences caused by the use of this information.

Before attempting to use the device, please read the relevant precautions of the device

carefully and be sure to comply with the installation and commissioning safety precautions

and operating procedures. For the possible hazards and damages caused by incorrect use

of the device, please refer to the following symbols.

Warn
This mark indicates

"Dangers caused by failure to follow the instructions may result in personal

Notice
This mark indicates

"Dangers caused by failure to follow the instructions may result in minor or

Tips
This mark indicates

“Make necessary supplements or explanations to the description of the

Target customers

This manual provides information about FS Installation and commissioning information for a

range of remote I/O modules, designed for engineers, installers, maintenance personnel and

electricians with general automation knowledge.

Recycling and Disposal

To ensure environmentally friendly recycling and disposal of your old device, please contact

a certified electronic waste disposal service.

Online Support

In addition to this manual, you can also obtain more product information by checking the

official website.

http://www.decowellauto.com
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1.System Overview
1.1 What is Remote IO

Remote I/O, also known as distributed I/O, refers to electronic devices commonly used in

process or factory automation that transmit and receive input and output signals to and from

main electronic equipment (such as DCS, PLC, or PC) via communication technologies like

industrial fieldbus.

1.2 Composition

The FS Series remote I/O modules mainly consist of system status indicators, system power

supply, input/output channels, communication interface, and I/O channel indicators, as

shown in Figure 1-2.

Figure 1-2 FS Series Remote IO Module composition

1.3 Features of the module

The FS Series remote I/O modules feature an integrated design that combines the

communication interface, input/output I/O interfaces, system and I/O indicators. They are

characterized by high integration, rich communication protocols, compact size, and ease of

use.

1.4 Application areas

The FS Series remote I/O modules are widely used across various fields, such as new

energy, lithium battery, non-standard automation, robotics, CNC machines, intelligent

parking systems, logistics sorting, educational equipment, environmental protection, and

heating systems.
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2.Module parameters
2.1 Naming conventions

2.2 Module communication protocol interface parameters

It mainly introduces parameters such as bus protocol, interface type, interface mode and

communication rate in the module.

2.2.1 PROFINET protocol

PROFINETModule Communication Protocol Interface Parameters

Bus protocol PROFINET

Interface Type Industry EtherNET

Interface 2×RJ45

Communication rate 100Mbps

Communication distance 100m (distance between stations)

Electrical isolation have

PN Module system indicator light description

NO.
Indicator

Lights
Illustrate Color State Meaning

1 POWER
Power
indicator

green
ON Power supply is normal

OFF The power supply is disconnected or faulty.

2 RUN
Running

indicator light
green

ON Equipment running and the communication is normal

OFF No power or system abnormality

3 SF --- --- --- ---

4 BF
System fault
indicator

red
ON Communication abnormality

OFF Equipment running and the communication is normal
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PN2 Module system indicator light description

No.
Indicator

Lights
illustrate color state meaning

1 POWER
Power
indicator

green
ON Power supply is normal

OFF The power supply is disconnected or faulty.

2 RUN
Running

indicator light
green

ON
The equipment is running and the

communication is normal

OFF No power or system abnormality

3 SF --- --- --- ---

4 BF
System fault
indicator

red

ON Communication abnormality

OFF
The equipment is running and the

communication is normal

5 MT
Maintenance
indicator

green

Flash 5HZ Flashing during the upgrade process

Flash 1HZ Flashes when the reset button is pressed

ON Reset operation completed

OFF Non-maintenance status

2.2.2 EtherCAT protocol

EtherCATModule communication protocol interface parameters

Bus protocol EtherCAT

Interface Type Industry EtherNET

Interface 2×RJ45

Communication rate 100Mbps

Communication distance 100m (distance between stations)

Electrical isolation have

EtherCAT Module system indicator light description

NO. Indicator Lights illustrate color state meaning

1 POWER Power indicator green
ON Power supply is normal

OFF
The power supply is disconnected or

faulty.

2 RUN
Running

indicator light
green

ON OP Status, running normally

OFF INIT Status, initialization status

Flash
PRE-OP Status, communication

initialization completed

Single flash
SAFE-OP Status, SDO and PDO

Unavailable

3 ERR
System fault
indicator

red

ON Application controller failure

OFF No Error

Flashes twice
Process data watchdog

timeout/EtherCAT watchdog timeout

Flash once Local Error

Flash Configuration Error
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2.2.3 CC-Link protocol

 CC-Link module communication protocol interface parameters

CC-Link module communication protocol interface parameters

Bus protocol CC-Link

Working Mode CC-Link remote I/O station

Connection Shielded twisted pair

Communication rate 156kbps～10Mbps

Address Configuration 1~64

Electrical isolation have

 CC-Link remote IO Module DIP Setting

CC Link module system indicator light description

NO. Indicator Lights illustrate color state meaning

1 POWER Power indicator green

ON Power supply is normal

OFF
The power supply is

disconnected or faulty.

2 RUN
Running

indicator light
green

ON
The equipment is running and
the communication is normal

OFF Connection not established

3 ERR
System fault
indicator

red

ON
Module communication

abnormality

OFF
Module communication is

normal

2.2.4 DeviceNet protocol

 DeviceNet module communication protocol interface parameters

DeviceNet Module communication protocol interface parameters

Bus protocol DeviceNet

Connection Shielded twisted pair

Communication rate 125kbps/250kbps/500kbps

Address Configuration 0~63

Electrical isolation have

CCLink communication rate setting

Dial position

number

Communicatio

n rate

Corresponding

transmission distance

0 156kbps 1200m

1 625kbps 600m

2 2.5Mbps 200m

3 5Mbps 150m

4 10Mbps 100m



FS Series Remote IO User Manual

11

 DeviceNet Remote IO Module communication interface definition

 DeviceNet Remote IO Module DIP Setting

DeviceNet module system indicator light description

NO.
Indicator

Lights
illustrate color state meaning

1 POWER Power indicator green

ON Power supply is normal

OFF
The power supply is disconnected or

faulty.

2 RUN
Running

indicator light
green

ON
The equipment is running and the

communication is normal

OFF Connection not established

3 ERR
System fault
indicator

red
ON Module communication abnormality

OFF Module communication is normal

2.2.5 CC-LinkIE FieldBASIC Protocol

CC-Link IE Field BasicModule communication protocol interface parameters

Bus protocol CC-Link IE Field Basic

Interface Type Industry EtherNET

Interface 2×RJ45

Communication rate 100Mbps

Communication distance 100m (distance between stations)

Electrical isolation have

CC-Link IE Field BASIC module system indicator light description

DeviceNet communication interface Position No. Signal Signal Definition

1 V+ Positive power supply

2 CH Data signal positive

3 SLD Shielded wire

4 CL Data signal negative

5 V- Negative pole of power supply

DeviceNet communication rate setting

0 125kbps

1 250kbps

2 500kbps
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NO. Indicator Lights illustrate color state meaning

1 POWER Power indicator green
ON Power supply is normal

OFF The power supply is disconnected or faulty.

2 RUN
Running

indicator light
green

ON
The equipment is running and the

communication is normal

OFF Connection not established

Flash Factory reset signal detected

3 ERR
System fault
indicator

red
ON Module communication abnormality

OFF Module communication is normal

2.2.6 CANopen protocol

 CANopen module communication protocol interface parameters

CANopen module communication protocol interface parameters

Bus protocol CANopen

Connection Shielded twisted pair

Communication rate 10kbps～1Mbps

Address Settings DIP switch settings

Communication distance
The maximum communication distance is determined by the

communication rate

Electrical isolation have

 CANopen remote IO Module communication interface definition

 CANopen remote IO Module DIP Setting

CC-LinkIE FieldBASIC module system indicator light description

CANopen communication interface Position No. Signal Signal Definition

1 +V Positive power supply

2 CH Data signal positive

3 SLD Shielded wire

4 CL Data signal negative

5 -V Negative pole of power supply

CANOpen communication rate setting

0 10kbps

1 20kbps

2 50kbps

3 100kbps

4 125kbps

5 250kbps

6 500kbps

7 1000kbps



FS Series Remote IO User Manual

13

NO. Indicator Lights illustrate color state meaning

1 POWER
Power
indicator

green

ON Power supply is normal

OFF
The power supply is disconnected or

faulty.

2 RUN
Running

indicator light
green

ON
The module enters the operating state and

the communication is normal.

OFF The module enters the initialization state

1 flash
long off

The module enters the operation stop state

5HZ Flash The module enters pre-operationstate;

3 ERR
System fault
indicator

red
ON Module failure

OFF The module enters the running state

2.2.7 EtherNet/IP protocol

EtherNet/IP Module communication protocol interface parameters

Bus protocol EtherNet/IP

Interface Type Industry EtherNET

Interface 2×RJ45

Communication rate 100Mbps

Communication distance 100m (distance between stations)

Electrical isolation have

EtherNet/IPModule system indicator light description

NO.
Indicator

Lights
illustrate color state meaning

1 POWER Power indicator green
ON Power supply is normal

OFF The power supply is disconnected or faulty.

2 MS
Module status

indicator

green
ON The equipment is operating normally

1HZFlash Standby, device not configured yet

Red and
Green

1HZFlash
Self-test, the device is performing a

power-on test

OFF The device has no power

red

ON
Main faults: The device has detected a

major, unrecoverable fault.

1HZFlash
No power supply:The device is missing

power.

3 NS
Network status

indicator

green

ON
Connected, the device has at least one

established connection

1HZFlash
No connection, the device has not

established a connection

Red and
Green

1HZFlash
Self-test, the device is performing a

power-on test

OFF No power or no IP address
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red

ON Repeat IP address

1HZFlash
Connection timed out. One or more

connections to this device have timed out.

4 MT
Maintenance
indicator

green

Flash 5HZ Flashing during the upgrade process

Flash 1HZ Flashes when the reset button is pressed

ON Reset operation completed

OFF Non-maintenance status

2.3 Module input/output channel technical parameters

2.3.1 XX-8800-C0NN

Tip: XX represents the bus protocol to be selected (for example:PN、EC, CL, CI, CA etc.), the

input and output parameters and external dimensions of the modules are consistent.

 XX-8800-C0NN Integrated module model

model Specifications

XX-8800-C0NN 8-channel digital input (NPN & PNP) 8-channel digital output (NPN)

XX-8800-C1NN 8-channel digital input (NPN & PNP) 8-channel digital output (PNP)

XX-8800-C2NN 8-channel digital input (NPN & PNP) 8-channel digital output (relay)

XX-HH00-C0NN 16-channel digital input (NPN & PNP) 16-channel digital output (NPN)

XX-HH00-C1NN 16-channel digital input (NPN & PNP) 16-channel digital output (PNP)

XX-S000-CNNN 32 digital inputs (NPN & PNP)

XX-0S00-N0NN 32 digital outputs (NPN)

XX-0S00-N1NN 32 digital outputs (PNP)

 Module parameter introduction

Technical Parameters

model XX-8800-C0NN

Product Name 8-channel digital input (NPN & PNP) 8-channel digital output (NPN)

Bus protocol
PROFINET,EtherCAT,CC-Link,DeviceNet

CC-LinkIE Field Basic, CANopen

Rated input voltage 24V(18~36V）

Current consumption 38mA

Input channel parameters

Number of input channels 8

Input signal type NPN&PNP compatible (Transistor)

NPN Signal Level 0～5V

PNP Signal Level 15~30V

Current consumption per
channel

5mA

Port protection Overvoltage protection
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2.3.2 XX-8800-C1NN

Tip: XX represents the bus protocol to be selected (for example:PN、EC, CL, CI, CAetc.), the

input and output parameters and external dimensions of the modules are consistent.

 XX-8800-C1NNIntegrated module model

model Specifications

XX-8800-C0NN 8-channel digital input (NPN & PNP) 8-channel digital output (NPN)

XX-8800-C1NN 8-channel digital input (NPN & PNP) 8-channel digital output (PNP)

XX-8800-C2NN 8-channel digital input (NPN & PNP) 8-channel digital output (relay)

XX-HH00-C0NN 16-channel digital input (NPN & PNP) 16-channel digital output (NPN)

XX-HH00-C1NN 16-channel digital input (NPN & PNP) 16-channel digital output (PNP)

XX-S000-CNNN 32 digital inputs (NPN & PNP)

XX-0S00-N0NN 32 digital outputs (NPN)

XX-0S00-N1NN 32 digital outputs (PNP)

 Module parameter introduction

Electrical isolation AC500V

Output channel parameters

Number of output
channels

8

Input signal type NPN(transistor)

Rated level 0V(Max: 1.5V）

Single channel rated
current

Max: 0.5A（8The total current output by the channels is 2A）

Port protection Overvoltage and overcurrent protection

Electrical isolation AC500V

Physical parameters

Dimensions 90mm×100mm×45.4mm

Operating temperature -10~55℃

Storage temperature -25~85℃

Relative humidity 95% non-condensing

Protection level IP20

Technical Parameters

model XX-8800-C1NN

Product Name 8-channel digital input (NPN & PNP) 8-channel digital output (PNP)

Bus protocol
PROFINET,EtherCAT,CC-Link,DeviceNet

CC-LinkIE Field Basic, CANopen

Rated input voltage 24V(18~36V）

Current consumption 38mA
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2.3.3 XX-8800-C2NN

Tip: XX represents the bus protocol to be selected (for example:PN、EC, CL, CI, CAetc.), the

input and output parameters and external dimensions of the modules are consistent.

 XX-8800-C2NNIntegrated module model

model Specifications

XX-8800-C0NN 8-channel digital input (NPN & PNP) 8-channel digital output (NPN)

XX-8800-C1NN 8-channel digital input (NPN & PNP) 8-channel digital output (PNP)

XX-8800-C2NN 8-channel digital input (NPN & PNP) 8-channel digital output (relay)

XX-HH00-C0NN 16-channel digital input (NPN & PNP) 16-channel digital output (NPN)

XX-HH00-C1NN 16-channel digital input (NPN & PNP) 16-channel digital output (PNP)

XX-S000-CNNN 32 digital inputs (NPN & PNP)

XX-0S00-N0NN 32 digital outputs (NPN)

XX-0S00-N1NN 32 digital outputs (PNP)

Input channel parameters

Number of input
channels

8

Input signal type NPN&PNP Compatible (Transistor)

NPN signal Level 0～5V

PNP signal Level 15~30V

Current consumption
per channel

5mA

Port protection Overvoltage protection

Electrical isolation AC500V

Output channel parameters

Number of output
channels

8

Input signal type PNP(transistor)

Rated level 24V(18~36V）

Single channel rated
current

Max: 0.5A（8The total current output by the channels is 2A）

Port protection Overvoltage and overcurrent protection

Electrical isolation AC500V

Physical parameters

Dimensions 90mm×100mm×45.4mm

Operating temperature -10~55℃

Storage temperature -25~85℃

Relative humidity 95% non-condensing

Protection level IP20
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 Module parameter introduction

2.3.4 XX-HH00-C0NN

Tip: XX represents the bus protocol to be selected (for example:PN、EC, CL,CI,CAetc.), the

input and output parameters and external dimensions of the modules are consistent.
 XX-HH00-C0NNIntegrated module model

model Specifications

XX-8800-C0NN 8-channel digital input (NPN & PNP) 8-channel digital output (NPN)

Technical Parameters

model XX-8800-C2NN

Product Name 8-channel digital input (NPN & PNP) 8-channel digital output (relay)

Bus protocol
PROFINET,EtherCAT,CC-Link,DeviceNet

CC-LinkIE Field Basic, CANopen

Rated input voltage 24V(18~36V）

Current consumption 38mA

Input channel parameters

Number of input
channels

8

Input signal type NPN&PNPCompatible (Transistor)

NPNSignal Level 0～5V

PNPSignal Level 15~30V

Current consumption
per channel

5mA

Port protection Overvoltage protection

Electrical isolation AC500V

Output channel parameters

Number of output
channels

8

Input signal type Relay (normally open)

Rated level 240VAC/30VDC

Single channel rated
current

5A

Port protection Overvoltage and overcurrent protection

Electrical isolation AC500V

Physical parameters

Dimensions 90mm×100mm×45.4mm

Operating temperature -10~55℃

Storage temperature -25~85℃

Relative humidity 95% non-condensing

Protection level IP20
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XX-8800-C1NN 8-channel digital input (NPN & PNP) 8-channel digital output (PNP)

XX-8800-C2NN 8-channel digital input (NPN & PNP) 8-channel digital output (relay)

XX-HH00-C0NN 16-channel digital input (NPN & PNP) 16-channel digital output (NPN)

XX-HH00-C1NN 16-channel digital input (NPN & PNP) 16-channel digital output (PNP)

XX-S000-CNNN 32 digital inputs (NPN & PNP)

XX-0S00-N0NN 32 digital outputs (NPN)

XX-0S00-N1NN 32 digital outputs (PNP)

 Module parameter introduction

Technical Parameters

model XX-HH00-C0NN

Product Name 16-channel digital input (NPN & PNP) 16-channel digital output (NPN)

Bus protocol
PROFINET,EtherCAT,CC-Link,DeviceNet

CC-LinkIE Field Basic, CANopen

Rated input voltage 24V(18~36V）

Current consumption 40mA

Input channel parameters

Number of input
channels

16

Input signal type NPN&PNPCompatible (Transistor)

NPN Signal Level 0～5V

PNP Signal Level 15~30V

Current consumption
per channel

5mA

Port protection Overvoltage protection

Electrical isolation AC500V

Output channel parameters

Number of output
channels

16

Input signal type NPN(transistor)

Rated level 0V(Max: 1.5V）

Single channel rated
current

Max: 0.5A（8The total current output by the channels is 2A）

Port protection Overvoltage and overcurrent protection

Electrical isolation AC500V

Physical parameters

Dimensions 90mm×100mm×45.4mm

Operating temperature -10~55℃

Storage temperature -25~85℃

Relative humidity 95% non-condensing
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2.3.5 XX-HH00-C1NN

Tip: XX represents the bus protocol to be selected (for example:PN、EC, CL,CI,CAetc.), the

input and output parameters and external dimensions of the modules are consistent.

 XX-HH00-C1NNIntegrated module model

model Specifications

XX-8800-C0NN 8-channel digital input (NPN & PNP) 8-channel digital output (NPN)

XX-8800-C1NN 8-channel digital input (NPN & PNP) 8-channel digital output (PNP)

XX-8800-C2NN 8-channel digital input (NPN & PNP) 8-channel digital output (relay)

XX-HH00-C0NN 16-channel digital input (NPN & PNP) 16-channel digital output (NPN)

XX-HH00-C1NN 16-channel digital input (NPN & PNP) 16-channel digital output (PNP)

XX-S000-CNNN 32 digital inputs (NPN & PNP)

XX-0S00-N0NN 32 digital outputs (NPN)

XX-0S00-N1NN 32 digital outputs (PNP)

 Module parameter introduction

Protection level IP20

Technical Parameters

model XX-HH00-C1NN

Product Name 16-channel digital input (NPN & PNP) 16-channel digital output (PNP)

Bus protocol
PROFINET,EtherCAT,CC-Link,DeviceNet

CC-LinkIE Field Basic, CANopen

Rated input voltage 24V(18~36V）

Current consumption 40mA

Input channel parameters

Number of input
channels

16

Input signal type NPN&PNPCompatible (Transistor)

NPNSignal Level 0～5V

PNPSignal Level 15~30V

Current consumption
per channel

5mA

Port protection Overvoltage protection

Electrical isolation AC500V

Output channel parameters

Number of output
channels

16

Input signal type PNP(transistor)

Rated level 24V(18~36V）

Single channel rated Max: 0.5A（8The total current output by the channels is 2A）
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2.3.6 XX-S000-CNNN

Tip: XX represents the bus protocol to be selected (for example:PN、EC, CL,CI,CAetc.), the

input and output parameters and external dimensions of the modules are consistent.

 XX-S000-CNNNIntegrated module model

model Specifications

XX-8800-C0NN 8-channel digital input (NPN & PNP) 8-channel digital output (NPN)

XX-8800-C1NN 8-channel digital input (NPN & PNP) 8-channel digital output (PNP)

XX-8800-C2NN 8-channel digital input (NPN & PNP) 8-channel digital output (relay)

XX-HH00-C0NN 16-channel digital input (NPN & PNP) 16-channel digital output (NPN)

XX-HH00-C1NN 16-channel digital input (NPN & PNP) 16-channel digital output (PNP)

XX-S000-CNNN 32 digital inputs (NPN & PNP)

XX-0S00-N0NN 32 digital outputs (NPN)

XX-0S00-N1NN 32 digital outputs (PNP)

 Module parameter introduction

current

Port protection Overvoltage and overcurrent protection

Electrical isolation AC500V

Physical parameters

Dimensions 90mm×100mm×45.4mm

Operating temperature -10~55℃

Storage temperature -25~85℃

Relative humidity 95% non-condensing

Protection level IP20

Technical Parameters

model XX-HH00-C0NN

Product Name 32 digital inputs (NPN & PNP)

Bus protocol
PROFINET,EtherCAT,CC-Link,DeviceNet

CC-LinkIE Field Basic, CANopen

Rated input voltage 24V(18~36V）

Current consumption 40mA

Input channel parameters

Number of input
channels

32

Input signal type NPN&PNPCompatible (Transistor)

NPNSignal Level 0～5V

PNPSignal Level 15~30V

Current consumption 5mA
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2.3.7 XX-0S00-N0NN

Tip: XX represents the bus protocol to be selected (for example:PN、EC, CL,CI,CAetc.), the

input and output parameters and external dimensions of the modules are consistent.

 XX-0S00-N0NNIntegrated module model

model Specifications

XX-8800-C0NN 8-channel digital input (NPN & PNP) 8-channel digital output (NPN)

XX-8800-C1NN 8-channel digital input (NPN & PNP) 8-channel digital output (PNP)

XX-8800-C2NN 8-channel digital input (NPN & PNP) 8-channel digital output (relay)

XX-HH00-C0NN 16-channel digital input (NPN & PNP) 16-channel digital output (NPN)

XX-HH00-C1NN 16-channel digital input (NPN & PNP) 16-channel digital output (PNP)

XX-S000-CNNN 32 digital inputs (NPN & PNP)

XX-0S00-N0NN 32 digital outputs (NPN)

XX-0S00-N1NN 32 digital outputs (PNP)

 Module parameter introduction

per channel

Port protection Overvoltage protection

Electrical isolation AC500V

Physical parameters

Dimensions 90mm×100mm×45.4mm

Operating temperature -10~55℃

Storage temperature -25~85℃

Relative humidity 95% non-condensing

Protection level IP20

Technical Parameters

model XX-0S00-N0NN

Product Name 32 digital outputs (NPN)

Bus protocol
PROFINET,EtherCAT,CC-Link,DeviceNet

CC-LinkIE Field Basic, CANopen

Rated input voltage 24V(18~36V）

Current consumption 40mA

Output channel parameters

Number of output
channels

32

Input signal type NPN(transistor)

Rated level 0V(Max: 1.5V）

Single channel rated
current

Max: 0.5A（8The total current output by the channels is 2A）

Port protection Overvoltage and overcurrent protection
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2.3.8 XX-0S00-N1NN

Tip: XX represents the bus protocol to be selected (for example:PN、EC, CL,CI,CAetc.), the

input and output parameters and external dimensions of the modules are consistent.

 XX-HH00-C1NNIntegrated module model

model Specifications

XX-8800-C0NN 8-channel digital input (NPN & PNP) 8-channel digital output (NPN)

XX-8800-C1NN 8-channel digital input (NPN & PNP) 8-channel digital output (PNP)

XX-8800-C2NN 8-channel digital input (NPN & PNP) 8-channel digital output (relay)

XX-HH00-C0NN 16-channel digital input (NPN & PNP) 16-channel digital output (NPN)

XX-HH00-C1NN 16-channel digital input (NPN & PNP) 16-channel digital output (PNP)

XX-S000-CNNN 32 digital inputs (NPN & PNP)

XX-0S00-N0NN 32 digital outputs (NPN)

XX-0S00-N1NN 32 digital outputs (PNP)

 Module parameter introduction

Electrical isolation AC500V

Physical parameters

Dimensions 90mm×100mm×45.4mm

Operating temperature -10~55℃

Storage temperature -25~85℃

Relative humidity 95% non-condensing

Protection level IP20

Technical Parameters

model XX-0S00-N1NN

Product Name 32 digital outputs (PNP)

Bus protocol
PROFINET,EtherCAT,CC-Link,DeviceNet

CC-LinkIE Field Basic, CANopen

Rated input voltage 24V(18~36V）

Current consumption 40mA

Output channel parameters

Number of output
channels

32

Input signal type PNP(transistor)

Rated level 24V(18~36V）

Single channel rated
current

Max: 0.5A（8The total current output by the channels is 2A）

Port protection Overvoltage and overcurrent protection

Electrical isolation AC500V
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Physical parameters

Dimensions 90mm×100mm×45.4mm

Operating temperature -10~55℃

Storage temperature -25~85℃

Relative humidity 95% non-condensing

Protection level IP20
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3.Module Installation
3.1 Basics

FS protection level of the series modules is IP20, which means that FSThe series

modules can only be installed on rails, control cabinets or electrical operating rooms and in

dry environments (protection levelIP20). Safety protection must be provided in cabinets,

control cabinets or operating rooms to prevent electric shock and fire spread.

FS series modules can be mounted on mounting rails in accordance with EN 60715

(35×7.5 mm or 35×15 mm). In the control cabinet, separate grounding of the mounting rail is

required. Exception: If the rail is mounted on a grounded galvanized mounting plate,

separate grounding of the rail is not required.

3.2 Installation clearance

When installing and removing FS series modules, a minimum clearance must be maintained,

as shown in Figure 3-1.

Figure 3-1Minimum installation clearance

3.3 IO Module installation and removal

3.3.1 IO Module Installation

1. First, pull out the rail clip under the module with a flat-blade screwdriver;

2. Hang the module on DIN35On the rail, use a flat-blade screwdriver to push the rail clip at

the bottom into place and lock it, as shown in Figure 3-2 shown.
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Figure 3-2 Module Installation

3.3.2 IO Module removal

1. First, pull out the rail clip under the module with a flat-blade screwdriver;

2. Gently pull the module out andIN35The guide rail forms an angle, and then pushes the

module out of the net, as shown in Figure 3-3shown.

Figure 3-3Module removal
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4.Dimensions and Wiring Diagram
4.1 Module Dimensions

FS dimensions of all modules in the series are consistent, that is, the length, width and

height are equal.

Figure 4-1Module Dimensions

4.2Module power wiring diagram

The power wiring diagram for EtherCAT, PROFINET, CC-Link, and CC-Link IE Field

Basic remote I/O modules in the FS series is shown in Figure 4-3.

Figure 4-3Power wiring diagram

The wiring diagram of the DeviceNet remote I/O module in the FS series differs from that
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of modules using other bus protocols, as shown in Figure 4-4.

Figure 4-4Power wiring diagram

4.3 Digital input channel wiring diagram

In the FS series remote I/O modules, all input channels support both NPN and PNP

signal types; however, only one type—either NPN or PNP—can be used during operation.

4.3.1Digital input channel NPN Signal wiring diagram

Figure 4-5Digital input channels NPN connection
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4.3.1Digital input channel PNP Signal wiring diagram

Figure 4-5Digital input channels PNP connection

4.4 Digital output wiring diagram

4.4.1Digital output NPN Wiring Diagram

Figure 4-6Digital output channels NPN connection

Load
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4.4.2Digital output PNP Wiring Diagram

Figure 4-6Digital output channels PNP connection

4.5 Relay output wiring diagram

4.5.1 Relay output DC load wiring diagram

Figure 4-7 Relay output DC load wiring diagram

Load

Load

Load
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4.5.2 Relay output AC load wiring diagram

Figure 4-8 Relay output AC load wiring diagram

Load Load
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5.FS Series IO configuration
This chapter mainly introduces the connection and configuration of FS series remote I/O

modules with mainstream industrial PLC, including configuration in the programming

software and parameter settings of certain modules.

5.1 EtherCAT Protocol

5.1.1 TwinCAT3andEtherCATProtocol IO Module connections and configuration

1. Communication connection diagram, as shown in Figure 5-1-1shown.

Figure 5-1-1Communication connection diagram

2. Hardware configuration as shown in Table 5-1-2Shown

Table 5-1-2Hardware Configuration Table

Hardware Quantity Remark
Programming Computer 1 InstallTwinCAT3

EC-8800-C0NN 1 EtherCAT protocol 8DI/8DOModules
Network cable several

3, Install XML Description File

Installing XML description files into TwinCAT3As shown in Figure 5-1-3The default folder

for this example is (C:\TwinCAT\3.1\Config\Io\EtherCAT)

Figure 5-1-3Install XML Description File

PC
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4. New project and equipment configuration

Open TwinCAT3In the software, select "File" > New > Project from the menu bar, as

shown in Figure 5-1-4As shown, in the New Project window, select "TwinCATprojects”, as

shown in Figure 5-1-5shown.

Figure 5-1-4New Project

Figure 5-1-5Select TwinCATproject

I connected to the programming computerOScan to the project, click

"I/O">Devices”>”Scan”, as shown in Figure 5-1-6As shown, the scanned hardware

configuration is shown in Figure 5-1-7shown.

Figure 5-1-6 Scan IO device Figure 5-1-7 Hardware Configuration
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5.1.2 CODESYS and EtherCAT Protocol IO Module connections and configuration

1. Communication connection diagram, as shown in Figure 5-1-8shown.

Figure 5-1-8Communication connection diagram

2. Hardware configuration as shown in Table 5-1-2Shown

Table 5-1-2Hardware Configuration Table

hardware quantity Remark

Programming Computer 1 InstallCodesysV3.5

EC-8800-C0NN 1 EtherCAT protocol 8DI/8DOModules

Network cable several

3. Install XML Description File

Open CODESYS V3.5In the software, select "Tools" > "Device Repository" from the

menu bar, as shown in Figure 5-1-9shown.

Figure 5-1-9Install XML Device Description File

4. New project and equipment configuration

Open CODESYS V3.5Software, select New Project > Project > Standard project”, as

shown in Figure 5-1-10shown.

PCPC
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Figure 5-1-10New Construction

In the standard project window, select "CODESYS SoftMotionWinV3”,PLC_PRGSelect

"Structured Text (ST)”, as shown in Figure 5-1-11shown.

Figure 5-1-11Select device and programming language

Tip: Softmotion can drive and I/O, Control can only take I/OBut not with drive.

In the device tree, "Device (CODESYS SoftMotionWinV3)”>”Add device”, as shown in

Figure 5-1-12As shown, in the Add Device window, select Fieldbus > EtherCAT">EtherCAT

Master”, as shown in Figure 5-1-13 shown.



FS Series Remote IO User Manual

35

Figure 5-1-12Add a device

Figure 5-1-13 Choose EtherCAT bus

For EtherCAT Master allocates the network port, double-click "EtherCAT_Master”>

“EtherCAT NICSettings > Browse, as shown in Figure 5-1-14shown.

Figure 5-1-14Assign network port

Tip: Before assigning the network port, you need to download the project to the controller

Manually IO Add the module to the device tree, right-click "EtherCAT Master">"Add Device",

select "EC-8800-C0NN”, as shown in Figure 5-1-15shown.
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Figure 5-1-15Add the module to the device tree

5. Download and monitor the program

Select "Online" > "Login to" from the menu bar,Confirm the download, then start the program and

select "Debug" > "Start" in the menu bar.

5.1.3 Sysmac Studio and EtherCAT Protocol I/O Module

1. Communication connection diagram, as shown in Figure 5-1-16shown.

Figure 5-1-16 Communication connection diagram

2. Hardware configuration is shown in Table 5-1-3Shown

Table 5-1-3Hardware Configuration Table

Hardware Quantity Remark

Programming Computer 1 Sysmac Studio

Controller 1 NJN301-1100

EC-8800-C0NN 1 EtherCAT protocol 8DI/8DOModules

Network cable several

3. New project and equipment configuration

Open Sysmac Studio, select "New Project" and configure the device model and version

number, as shown in Figure 5-1-18 shown.

PC
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Figure 5-1-17 New Construction

4. Install XML Description File

As shown in Figure 5-1-17 Open Sysmac Studio's ESI library, click "Install (file)", Select

the XML file and confirm, then wait for the installation to complete.

Figure 5-1-18 Display ESI library

To add an adapter, double-click "EtherCAT" in the Multiview Explorer, select "FS Series" in

the Toolbox, and then select "EC-8800-C0NN-V3" at the bottom of the Toolbox, as shown in

Figure 5-1-19.
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Figure 5-1-19 Adding Modules

Click the online icon, right-click the mouse on the icon of the master device, and select

Write Slave Device Node Address (the default node of the WELL-LINK EtherCAT slave

device is 0, so the node number must be set), as shown in Figure 5-1-20shown.

Figure 5-1-20Node address write

Note: After writing the node address, the device needs to be restarted for the node address to

take effect.

After the device restarts, download the program to the controller. Select "Controller" >

"Transfer" > "Transfer to Controller (T)" in the menu bar, as shown in Figure 5-twenty oneas

shown, and execute the download.
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Figure 5-1-21Program Download

5.2 PROFINET Protocol

5.2.1 TIA Portal and PROFINET Protocol IO Module connections and configuration

1. Communication connection diagram, as shown in the figure5-2-1shown.

Figure 5-2-1Communication connection diagram

2. Hardware configuration as shown in the table5-2-1Shown

surface5-2-1Hardware Configuration Table

Hardware Quantity Remark

Programming Computer 1 Install TIA Portal V16

Controller 1 S7-1511

PN-HH00-C1NN 1 PROFINET16DI/16DOModul es

Network cable several

3. Installation GSD document

Open TIA Portal V16, select "Options" > "Support Device Description Files (GSD)”, as

shown in the figure5-2-2shown.

PC
S7-1511
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Figure 5-2-2Install GSD document

4. New project and equipment configuration

Open TIA Portal V16, select New Project and configure, as shown in the figure5-2-3.

Figure 5-2-3New Construction

Configure the device, switch to the network view window, expand the hardware directory

on the right, and select PN-HH00-C1NNDrag it to the network view, as shown in the

figure5-2-4shown.

Figure 5-2-4 Configuring the device
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In the network view for remote IO module assignment controller, mouse click IOIn the

module "Not assigned", select PLC_1.PROFINET interface_1, as shown in the

figure5-2-5shown.

Figure 5-2-5Allocation IO Controller

Setting I/OModule IPAddress, in the device view, double-click the module to enter the

property view, as shown in the figure5-2-6shown.

Figure 5-2-6Allocation IP address

remoteAssign device names to I/O modules. Right-click the module and select “Assign

device name” as shown in Figure 5-2-7. Select the interface type and update the list and

assign a name as shown in Figure 5-2-8.

Figure 5-2-7 Assigning a Device Name Figure 5-2-8 Write device name
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Select all devices in the network view and download, as shown in the figure5-2-9As

shown, after the program is downloaded, start CPURun and switch to online monitoring to

see if the communication is normal, as shown in the figure5-2-10shown.

Figure 5-2-10Program Download

+

Figure 5-2-11Equipment Monitoring

5.2.2 Step7 Smart and PROFINET protocol IO moduleConnection and configuration

1. Communication connection diagram, as shown in the figure5-2-12shown.

Figure 5-2-12Communication connection diagram

2. Hardware configuration as shown in the table5-2-2Shown

PC
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Table 5-2-2 Hardware Configuration Table

Hardware Quantity Remark

Programming

Computer
1 InstallSTEP7-MicroWIN SMART

Controller 1 CPU ST40(DC/DC/DC)

PN-HH00-C1NN 1 PROFINETprotocol16DI/16DOModules

Network cable several

3. Install GSD document

OpenSTEP7-MicroWIN SMART, select "GSDML Management”, as shown in the

figure5-2-13shown.

Figure 5-2-13Install GSD document

4. Assign device name

In the menu bar, select "Tools" > "Find PROFINET Devices". In the window that appears,

select the network card connected to the module and search for devices. Select the module

from the network and edit its device name, as shown in Figure 5-2-14.

Notice:

① When selecting a network card, two options will appear for the same network card, as
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shown in the figure below. Here, select the network card without Auto.

②After assigning the device name, make sure that the device name used when configuring

the IO module is exactly the same as the one assigned above; otherwise, the PLC will not be

able to communicate properly with the IO module.

Figure 5-2-14Assigning a Device Name

5. New Project and Equipment Configuration

From the menu bar, select Tools > PROFINET”, select PLCThe role is the controller, as

shown in the figure5-2-15As shown, add IOmodule and assign a device name (which must

be the same as the device name assigned in step 4 above) andPAddress and confirm the

generation, as shown in the figure5-2-16shown.

Figure 5-2-15Select PLC Role
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Figure 5-2-16Assign a device name and IP address

6、Program download

In the menu bar, select "PLC" > "Download", then in the communication window, choose

"Find CPU". Select the PLC to which you want to download the program, and proceed with

the download.

Note: When using STEP 7-MicroWIN SMART to configure PROFINET communication for

the S7-200 SMART, the CPU firmware version must be ≥ V2.4. For firmware version V2.3,

an online firmware upgrade is supported. However, for firmware versions below V2.3, the

firmware must be updated using a memory card inserted into the CPU.

5.2.3 CODESYS and PROFINET protocol IO module Connection and configuration

1. Communication connection diagram, as shown in the figure 5-2-17 shown.

Figure 5-2-17Communication connection diagram.

PC
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2. Hardware configuration as shown in the table5-2-4Shown

surface5-2-4Hardware Configuration Table

hardware quantity Remark

Programming

Computer
1 InstallCodesysV3.5

PN-HH00-C1NN 1 PROFINETprotocol16DI/16DOModules

Network cable several

2. Install GSDdocument

Open CODESYS V3.5Software, select "Tools" > "Device Repository" from the menu bar,

as shown in the figure5-2-18shown.

Figure 5-2-18Install GSD document

4, New Project and Equipment Configuration

Open CODESYS V3.5Software, select New Project > Project > Standard project”, as

shown in the figure5-2-19shown.
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Figure 5-2-19New Construction

In the standard project window, select "CODESYS SoftMotion Win V3" as the device,

and choose "Structured Text (ST)" as the programming language for PLC_PRG, as shown in

Figure 5-2-20.

Figure 5-2-20Select device and programming language

In the device tree, go to "Device (CODESYS SoftMotion Win V3)" > "Add Device", and add

both the Ethernet adapter and the PROFINET IO Controller, as shown in Figures 5-2-21 and

5-2-22.

Tip: When configuring PROFINET IO in the native CODESYS software, if an error occurs due to a

missing library, the user needs to manually double-click the Library Manager. In the Library Manager

window, select and download the missing library—this process requires an active internet

connection.
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Additionally, pay attention to the IP address and subnet of the network port connected to the IO

device. Make sure they are in the same subnet when setting the IP address of the IO device to avoid

communication issues.

Figure 5-2-21Adding an Ethernet Adapter

Figure 5-2-22Add PROFINET IOMain Station

In the device tree, double-click "Ethernet" to assign the Ethernet port and configure the

IP parameters of the PROFINET IO Controller, as shown in Figures 5-2-23 and 5-2-24.

Figure 5-2-23 Ethernet allocation network port
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Figure 5-2-24Setting PROFINET IO Master Station IP

Download the program to the controller and start it. Then exit login mode. Right-click

PN_Controller and select "Scan Devices". In the device window, select the module and

assign the device name and IP address, as shown in Figure 5-2-25.Then, copy the device

into the project, as shown in Figure 5-2-26.

Figure 5-2-25Assign a name to IP address

Figure 5-2-26Copy the device to the project
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5. Program download and device monitoring

Download the project to the controller and start running and monitoring, as shown in the

figure5-2-27shown.

Figure 5-2-27Program download and monitoring

5.3 CC-Link IE Field Basic protocol

5.3.1 GX-Works2 and CC-Link IE Field Basic protocol IO module connections and
configuration

1. Communication connection diagram, as shown in the figure5-3-1shown.

Figure 5-3-1Communication connection diagram

2. Hardware configuration is shown in Table 5-3-1shown.

Table 5-5-1 Hardware Configuration Table

hardware quantity Remark
Programming Computer 1 Installing GX-Works2

Controller 1 L02
CI-HH00-C0NN 1 CC-Link IE Field Basic Protocol 16DI/16DO Module
Network cable several

PC
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3. Description file installation

Open the GX-Works2 programming software. From the menu bar, select “Tool” >

“Profile” > “Login”, as shown in Figure 5-3-1, and then select the description file that needs to

be installed.

Figure 5-3-1Description file installation

4. New construction projects

Open the GX-Works2 software. From the menu bar, select “Project” > “New”, then

choose the PLC series, CPU type, and programming language. In this case, the L-series

CPU is used as an example, as shown in Figure 5-3-2.

.

Figure 5-3-2Select PLC type

To configure CC-Link IE Field Basic parameters, go to the left navigation window and select

“Parameter” > “PLC Parameter”. In the L parameter settings window, choose “Built-in

Ethernet Port Settings”, then set the IP address and subnet mask for the PLC master station.

After completing the settings, click “CC-Link IE Field Basic Settings”, as shown in Figure
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5-3-3.

Figure 5-3-3Setting PLC IP Address

In the CC-Link IE Field Basic settings window, check the option “Use CC-Link IE Field Basic”,

and then click “Network Configuration Settings”, as shown in Figure 5-3-4.

Figure 5-3-4 Network Configuration Settings

Method 1 for adding modules: Manual addition. In the CC-Link IE Field Basic

configuration window, drag the I/O modules from the right side directly into the CPU area at

the lower left for configuration, as shown in Figure 5-3-5.
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Figure 5-3-5Manually add modules

Method 2 for adding modules: Scan modules on the network into the device configuration. In

the CC-Link IE Field Basic configuration window, select “Auto-detect connected devices”, as

shown in Figure 5-3-6.

Figure 5-3-6Scan the network for modules

To modify the module’s IP address (default IP address: 192.168.1.88), double-click the

IP address field of the module in the CC-Link IE Field Basic configuration window to edit it.

After modifying, right-click the module’s IP address, select “Online” > “Reflect Slave
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Communication Settings” to apply the IP address change, as shown in Figure 5-3-7. Finally,

click “Reflect Settings and Close”, as shown in Figure 5-3-8.

Figure 5-3-7Modification Module IP address

Figure 5-3-8Reflect settings and close

I/O Mapping Configuration: In the CC-Link IE Field Basic configuration window, set the

starting address points for the remote I/O module’s inputs and outputs, as shown in Figure

5-3-9.
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Figure 5-3-9 IO Mapping Configuration

5.CC-Link IE Field Basic Output Point Mapping Method: Each slave occupies 64 points, i.e.,

64 DI and 64 DO. Here, the input and output points correspond to the starting addresses

X100 and Y100, respectively. The slave I/O point mapping is shown in Figure 5-3-10.

Figure 5-3-10Slave IOPoint Mapping

6. Diagnose communication status

After completing the parameter configuration, download the project to the PLC. You can

then check the communication status through online diagnostics. From the menu bar, select

“Diagnostics” > “CC-Link IE Field Basic Diagnostics”, and view the status of the slave I/O
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modules in the CC-Link IE Field Basic diagnostics window.

5.4 CC-Link protocol

5.4.1 GX-Works2 and CCLink protocol IO Module connections and configuration

1. Communication connection diagram, as shown in the figure5-4-1shown.

Figure 5-4-1Communication connection diagram

2. Hardware configuration as shown in the table5-4-1Shown

surface5-4-1Hardware Configuration Table

Hardware Quantity Remark

Programming Computer 1 InstallGX-Works2

PLC 1 Support CCLink protocol

CL-HH00-C0NN 1 CC-Linkprotocol 16DI/16DOModules

CCLink communication line several

3. New project and communication parameter configuration

Open the GX-Works2 software and select the actual CPU model used on site. Then, in the

project’s left navigation pane, go to “Parameter” > “Network Parameter” > “CC-Link”. In the

CC-Link parameter settings window, configure the CC-Link slave settings as shown in

Figure 5-4-2, and the CC-Link network parameters as shown in Figure 5-4-3.

PC



FS Series Remote IO User Manual

57

Figure 5-4-2Open CCLink parameter setting window

Figure 5-4-3 CC-Link parameter settings

4.CC-Link module communication address allocation diagram

FSSeries CCLink protocol remote IOModule as CCLink remote IOStation, each module

occupies 32DIand32DO(Mitsubishi CCLink protocol), module address allocation and use, as

shown in Figure 5-4-4shown.
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Figure 5-4-4 CC-Link address allocation

5.5 DeviceNet Protocol

5.5.1 CX-one and DeviceNet protocol IO Module connections and configuration

Tip: There are two configuration methods for communication between CX-One and EX-1010:

manual and automatic. For details, please refer to items 4 and 5 in section 5.3.1.

1. Communication connection diagram, as shown in Figure 5-5-1shown.

Figure 5-5-1Communication connection diagram

Note: The power interface on the DeviceNet adapter requires a separate DC 24V

power supply. Additionally, terminal resistors must be installed at both ends of the

network. The wiring method for the terminal resistors is shown in Figure 5-5-2.

Figure 5-5-2Terminal resistance wiring

Occupied Address:

Used Address:

Occupied Address:

Used Address:

Occupied Address:

Used Address:

Occupied Address:

Used Address:

PC
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2. Hardware configuration as shown in the table5-5-1Shown

surface5-5-1Hardware Configuration Table

Hardware Quantity Remark

Programming Computer 1 CX-one

Controller 1 CJ2M/CJ1W-DR2M

DN-HH00-C0NN 1 DeviceNet protocol 16DI/16DOModules

DeviceNet communication line several

3、Install EDS document

Open the CX-Integrator configuration software, select "Tools" > "DeviceNet Tools" >

"Edit Configuration File" > "Vendor ID/Equipment Type Table”, as shown in the

figure5-5-3shown.

Figure 5-5-3Install EDSdocument

4, Device Configuration (Auto Scan)

Open the CX-Integrator configuration software, in the menu bar select 'Network' >

'Communication Settings', and choose the PLC model as 'CJ2M (CPU Model: CPU31)', as

shown in Figure 5-5-4.
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Figure 5-5-4Configuration CPU

Automatic scanning, click the 'Online Work' button, double-click the DeviceNet

[CJ1W-DRM21] network (-), node (1), unit (0), and set the network name, then confirm the

transfer as shown in Figure 5-5-5. Double-click DN-HH00-C0NN to check if the Omron PLC

can detect the DN-HH00-C0NN slave station.

Figure 5-5-5Automatic scanning

5. Device Configuration (Manual Configuration)

On the right side, click "New Project", select "Insert Network", and select "DeviceNet" as

shown in the figure5-5-6shown.
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Figure 5-5-6Insert Network

In the inserted network, add Devive firstNet Communication Module CJ1W-DRM21, then

add IODevice, right-click the network icon > "Insert Component", select DN-HH00-C0NN, as

shown in the figure5-5-7shown.

Figure 5-5-7Add Remote IOModules

6, download configuration information

Right-click "CJ1W-DR2M” icon, select “Parameters” > “Edit”, as shown in the

figure5-5-8shown.
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Figure 5-5-8Open parameter editing

In the Edit Device Parameters window, select the "Register button" to register the slave

device, as shown in the figure5-5-9After successful registration, you can see the PLC

internal address corresponding to the input and output of the slave I/O module. Finally, click

the "Download" button to download the configuration information to the PLC, as shown in the

figure5-5-10After the download is complete, you can see that the NET RUN indicator on the

adapter is on and the SYS indicator flashes once per second.

Figure 5-5-9Slave Device Registration
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Figure 5-5-10Download Configuration

5.6 CAN open protocol

5.6.1 AutoShop with CANopen Protocol IO Modules

1. Communication connection diagram, as shown in Figure 5-6-1shown.

Figure 5-6-1 Communication connection diagram

Notice:The power interface on the CANopen adapter requires a separate DC 24V power

supply. Terminal resistors must be added to both end modules of the network. The wiring

method for the terminal resistors is shown in Figure 5-6-2.

PC
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Figure 5-6-2 Terminal resistance wiring

2. Hardware configuration is shown in Table 5-6-1Shown

Table 5-6-1Hardware Configuration Table

Hardware Quantity Remark

Programming Computer 1 AutShop

Controller 1 H5U-A8

CA-8800-C0NN 1 CANopen 8DI/8DO Modules

Communication line several

3. Create a project

Open the AutoShop software, select the actual model corresponding to H5U and create

a project. In the configuration panel on the left side of the project, double-click “CAN

(CANLink)”, change the protocol type to CANopen, and set the communication baud rate to

125 kbps, as shown in Figure 5-6-3.

Figure 5-6-3 CANOpen communication parameter settings
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Install EDS document

In the configuration panel on the left, right-click “CAN (CANopen)” and select “Add CAN

Configuration.” Then double-click the CANopen configuration. In the blank area of the

CANopen device list on the right side of the view, right-click and select “Import EDS,” as

shown in Figure 5-6-4.

Figure 5-6-4 Install EDS document

Right click "CAN（CANLink)" and select "Add CAN Config", and add CA-8800-C0NN

module, as shown in Figure 5-6-5As shown;
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Figure 5-6-5Add CANopen module

Double-click the CA-8800-C0NN module in the configuration panel, and configure the Node

ID (Note: The Node ID must match the actual address set by the DIP switch; otherwise,

communication will not function properly), as shown in Figure 5-6-7. Then check the I/O

mapping addresses of the actual CANopen module, as shown in Figure 5-6-8.

Figure 5-6-7Setting Node ID

Figure 5-6-8 I/OAddress Mapping

Tip: In this example, D700_L stores the values of the 8-channel digital outputs, while

D7400_L stores the values of the 8-channel digital inputs.

5.6.2 InoProShop with CANopen Protocol IO Modules

1. Communication connection diagram, as shown in Figure 5-6-9shown.
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Figure 5-6-9Communication connection diagram

Notice:The power interface on the CANopen adapter requires a separate DC 24V power

supply. Terminal resistors must be added to both end modules of the network. The wiring

method for the terminal resistors is shown in Figure 5-6-10.

Figure 5-6-10 Terminal resistance wiring

2. Hardware configuration is shown in Table 5-6-2Shown

Table 5-6-2Hardware Configuration Table

Hardware Quantity Remark

Programming Computer 1 InoProShop

Controller 1 AM401-1608

CA-8800-C0NN 1 CANopen 8DI/8DOModules

Communication line several

3. Install EDS document

OpenInoProShopProgramming software, select "Tools" > "Device Library" in the menu

bar, select "Install" in the device library window, and select the EDS File, as shown in Figure

5-6-11shown.

PC
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Figure 5-6-11Install EDSdocument

4. Create a project

Open the InoProShop programming software, create a new project, and select the actual

corresponding CPU model. In the project configuration panel on the left, double-click to open

“LocalBus Config,” then click on the CPU and select “CANopen Master,” as shown in Figure

5-6-12.
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Figure 5-6-12Configuration CANopen

In the device list on the left, double-click “CANOPEN (CANopen Master)” to configure

the communication parameters of the CANopen master, as shown in Figure 5-6-13.

Figure 5-6-13 Configuration CANopen master station communication parameters

Double-click to open “Network Configuration.” In the configuration window, drag and

drop “CA-8800-C0NN” from the third-party manufacturer list under the CANopen device list

into the network device list, as shown in Figure 5-6-14.
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Figure 5-6-14Add CANopen module

In the device list, double-click the CA-8800-C0NN module and configure the Node ID (Note:

The Node ID must match the address set by the physical DIP switch; otherwise,

communication will not function properly), as shown in Figure 5-6-15. Then check the I/O

mapping addresses of the actual CANopen module, as shown in Figure 5-6-16.

Figure 5-6-15Setting Node ID

Figure 5-6-16 I/OAddress Mapping
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5.7 EtherNet/IP Protocol

5.7.1 KV STUDIO With EtherNet/IP protocol IOModule connections and configuration

1. Communication connection diagram, as shown in Figure 5-7-1Shown

Figure 5-7-1Communication connection diagram

2、Hardware configuration as shown in Table 5-7-1Shown

Table 5-7-1Hardware Configuration Table

hardware quantity Remark

Programming Computer 1
KV STUDIO,IP Setting

Tool software

PLC 1 KV-7500

EI2-HH00-C1NN 1
EtherNet/IP Protocol

16DI/16DOModules

Communication line several

Module IP Address Settings

Open IP Setting Tool software, select the network card connected to the module, and

scan the online IO Module, as shown in Figure 5-7-2shown.

Figure 5-7-2Scan Online IOModules

PC
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Select the module in the scan list whose IP address needs to be modified (Note: the module

is set to BOOTP by default at the factory and has no IP address. After setting the IP address,

be sure to select "Static IP" as the startup mode), as shown in Figure 5-7-3.

Figure 5-7-3Setting IP address

Suggestion:

Since the module does not have an IP address by default, configure the PC's network adapter

IPv4 settings to be in the same subnet as the IP address you intend to assign to the module

before setting the module's IP.

4、Install EDS document

Open the KV STUDIO software, create a new project, and double-click “EtherNet/IP” in the

project device tree to open the EtherNet/IP settings window. In the EtherNet/IP settings

window, go to the menu bar and select “EDS File” > “Register,” as shown in Figure 5-7-4.

Figure 5-7-4Install EDS document



FS Series Remote IO User Manual

73

5. New project and equipment configuration

Open KV STUDIO software, create a new project, and double-click “EtherNet/IP” in the

project device tree to open the EtherNet/IP settings window. Manually add EI2-HH00-C1NN

to the EtherNet/IP list, as shown in Figure 5-7-5.

Figure 5-7-5Manually addEI2-HH00-C1NNTo EtherNet/IP List

Scan the EI2-HH00-C1NN adapter online (first ensure that the online module and the PLC

are on the same subnet). In the EtherNet/IP settings window, go to the menu bar and select

“File” > “Auto Configuration,” as shown in Figure 5-7-6.

Figure 5-7-6 Online EI2-HH00-C1NN Module scan up
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Apply configuration and download configuration and program to PLCand monitor the

module operation status, as shown in Figure 5-7-7 shown.

Figure 5-7-7Run and monitor

5.7.2 Machine Expert and EtherNet/IP protocol IO Module connections and
configuration

1. Communication connection diagram, as shown in Figure 5-7-8Shown

Figure 5-7-8Communication connection diagram

2、Hardware configuration as shown in Table 5-7-2Shown

Table 5-7-2Hardware Configuration Table

hardware quantity Remark

Programming Computer 1 Machine Expert,IP Setting Toolsoftware

PLC 1 M241

EI2-HH00-C1NN 1 EtherNet/IP Protocol 16DI/16DOModules

Communication line several

Module IP Address Settings

Open IP Setting Tool software, select the network card connected to the module, and

scan the online IO Module, as shown in Figure 5-7-9shown.

PC



FS Series Remote IO User Manual

75

Figure 5-7-9Scan Online IOModules

Select the module in the scan list whose IP address needs to be modified (Note: the

module is set to BOOTP by default at the factory and has no IP address. After setting the IP

address, be sure to select "Static IP" as the startup mode), as shown in Figure 5-7-10shown.

Figure 5-7-10Setting IPaddress

Recommendation: The module does not have an IP address by default. Before configuring the

module's IP address, first set the PC’s network adapter IPv4 to the same subnet as the IP address

you intend to assign to the module.

4. Install EDS document

Open Machine Expert V2.0Programming software, select "Tools" > "Device Repository"

in the menu bar, and select "Install" in the Device Repository window, as shown in Figure

5-7-2As shown, select EDS file "EI2-HH00-C1NN" and confirm the installation.



FS Series Remote IO User Manual

76

Figure 5-7-11Install EDSdocument

5. New project and equipment configuration

Open Machine Expert V2.0, create a project, and right-click "EtherNET_1"Select "Add

Device", as shown in Figure 5-7-12As shown,

In the Add Device window, select "Protocol Manager" > "Industrial Ethernet Manager",

as shown in Figure 5-7-13As shown, right-click "_" under the device tree(Industrial Ethernet

Manager)">"Add Device", in the device window, select "DECOWELL AUTOMATION

CO.,LTD", and select "EI2-HH00-C1NN", as shown in Figure 5-7-14shown.

Figure 5-7-12Add a device
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Figure 5-7-13Adding Industrial Ethernet Manager

Figure 5-7-14Add EI2-HH00-C1NN

Configure the parameters of EI2-HH00-C1NN by double-clicking “EI2-HH00-C1NN” in the

device tree. Set the IP address to a static IP address, as shown in Figure 5-7-15.

Figure 5-7-15Configuration IPaddress

To view the I/O address mapping, double-click “EI2-HH00-C1NN” in the device tree and
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navigate to the EtherNet/IP I/O Mapping section, as shown in Figure 5-7-16.

Figure 5-7-16 IOAddress Mapping

5.7.3 CODESYS and EtherNet/IP Protocol IOModule connections and configuration

1. Communication connection diagram, as shown in Figure 5-7-8Shown

Figure 5-7-17Communication connection diagram

2、Hardware configuration as shown in Table 5-7-3Shown

Table 5-7-3Hardware Configuration Table

hardware quantity Remark

Programming Computer 1 CodesysSP16,IP Setting Toolsoftware

PLC 1

EI2-HH00-C1NN 1 EtherNet/IP Protocol 16DI/16DOModules

Communication line several

Module IP Address Settings

Open IP Setting Tool software, select the network card connected to the module, and

scan the online IO Module, as shown in Figure 5-7-18shown.

PC
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Figure 5-7-18Scan Online IOModules

Select the module in the scan list whose IP address needs to be modified (Note: the

module is set to BOOTP by default at the factory and has no IP address. After setting the IP

address, be sure to select "Static IP" as the startup mode), as shown in Figure 5-7-19shown.

Figure 5-7-19Setting IP address

Recommendation: The module does not have an IP address by default. Before configuring the

module's IP address, first set the PC’s network adapter IPv4 to the same subnet as the IP address

you intend to assign to the module.

4. Install EDS document

Open the CODESYS SP16 programming software, go to the menu bar and select

“Tools” > “Device Repository.” In the Device Repository window, click “Install” as shown in

Figure 5-7-20. Then, select “General Version” > “EI2-HH00-C1NN” from the EDS folder and

confirm the installation.
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Figure 5-7-20 Install EDS document

5. New project and equipment configuration

Open CODESYS SP16, create a new project, and right-click on “Device” in the device tree,

then select “Add Device.” In the Add Device window, select “Ethernet,” as shown in Figure

5-7-21.

Next, right-click on “Ethernet” in the device tree and select “Add Device.” In the Add Device

window, choose “EtherNet/IP Scanner,” as shown in Figure 5-7-22.

Figure 5-7-21 Adding an Ethernet Adapter

Figure 5-7-22 Add Ethernet IP scanner

Configure the network card of the Ethernet adapter, double-click "Ethernet" under the
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device tree, open the page and select the network card that needs to communicate with the

EtherNet/IP slave, as shown in Figure 5-7-23 shown.

Figure 5-7-23 Configuring the Ethernet Adapter Network Card

Right-click the "EtherNet_IP_Scanner"Select "Add Device", select "EI2-HH00-C1NN",

as shown in Figure 5-7-24 shown.

Figure 5-7-24 Add EI2-HH00-C1NNModules

Configure the IP address of the EI2-HH00-C1NN adapter by double-clicking

“EI2-HH00-C1NN” in the device tree. Enter the IP address (make sure it matches the actual

IP address set on the module), as shown in Figure 5-7-25.
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Figure 5-7-25Configuration EI2-HH00-C1NNModule IPaddress

To view the I/O address mapping, double-click “EI2-HH00-C1NN” in the device tree and

go to the EtherNet/IP I/O Mapping section, as shown in Figure 5-7-26.

Figure 5-7-26View IO Address Mapping

5.7.4 Sysmac Studio and EtherNet/IP Protocol IO Module connections and
configuration

1. Communication connection diagram, as shown in Figure 5-7-27Shown

Figure 5-7-27Communication connection diagram

2、Hardware configuration as shown in Table 5-7-4Shown

PC
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Table 5-7-4Hardware Configuration Table

hardware quantity Remark

Programming Computer 1
Sysmac Studio,IP

Setting Toolsoftware

NX1P2 1

EI2-HH00-C1NN 1
EtherNet/IP Protocol

16DI/16DOModules

Communication line several

Module IPAddress Settings

Open IP Setting Tool software, select the network card connected to the module, and

scan the online IO Module, as shown in Figure 5-7-28shown.

Figure 5-7-28Scan Online IO Modules

Select the module in the scan list whose IP address needs to be modified (Note: the

module is set to BOOTP by default at the factory and has no IP address. After setting the IP

address, be sure to select "Static IP" as the startup mode), as shown in Figure 5-7-29

shown.
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Figure 5-7-29Setting IPaddress

Recommendation: The module does not have an IP address by default. Before configuring the

module's IP address, first set the PC’s network adapter IPv4 to the same subnet as the IP address

you intend to assign to the module.

4. New project and equipment configuration

Open the Sysmac Studio programming software to create a project, and configure the EtherNet/IP

port with a fixed IP address (matching the actual PLC port IP), as shown in Figure 5-7-30.

Figure 5-7-30 EtherNet/IP Port Settings

Create all variables, create input and output variables in the global variables, and the

length of the variables must be consistent with the actual
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The input and output byte lengths in the module are consistent, as shown in the figure

5-7-31 shown.

Figure 5-7-31Creating Global Variables

In the menu bar, select “Tools” > “EtherNet/IP Connection Settings”. In the EtherNet/IP

List window, double-click the node address to open the EtherNet/IP Port Connection

Settings window, as shown in Figure 5-7-32.

Figure 5-7-32 Open the built-in EtherNet/IP port setting connection setting window

Register variables. In the built-in EtherNet/IP port setting connection setting window,

select the "Tag Group" window and click "Register All" to register the newly created global

variables, as shown in Figure 5-7-33 shown.
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Figure 5-7-33Global variable registration

To install the EDS file, in the opened Built-in EtherNet/IP Port Connection Settings window,

right-click on the blank area of the toolbox on the right and select “Show EDS Library”, as

shown in Figure 5-7-34. In the EDS Library window, select “Install” and open the EDS file to

be installed, as shown in Figure 5-7-35.

Figure 5-7-34 Display EDS Library
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Figure 5-7-35Install EDS document

Add the device to be communicated with and configure its parameters. In the toolbox,

select “Add Target Device”, as shown in Figure 5-7-36. The user needs to enter the

EtherNet/IP slave IP address, slave model, and revision version. After completion, click the

“Add” button at the lower left of the dialog box.

Figure 5-7-36Add target device

In the toolbox, set the target device "192.168.1.65 EI2-HH00-C1NNVersion 1" and drag

it to the connection, as shown in Figure 5-7-37As shown,

Configure the target device parameters,EI2-HH00-C1NNEnter the target variable as 100,

the output target variable is 101, the input and output byte sizes are both 10, select the

registered global variable as the starting variable, as shown in Figure 5-7-38As shown;

Switch the PLC to online mode and then to program mode, then select “Transfer to

Controller”, as shown in Figure 5-7-39.

Figure 5-7-37Adding a connected device
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Figure 5-7-38Configure target device parameters

Figure 5-7-39EtherNet/IP Configuration transfer to controller
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Appendix

FS Series product ordering information

FS integrated-PROFINET communication protocol digital input and output module

Product Model Product Description Order Number

PN-8800-C0NN
PROFINET 8-channel digital input (NPN & PNP)

8-channel digital output (NPN)
00-01-01

PN-8800-C1NN
PROFINET 8-channel digital input (NPN & PNP)

8-channel digital output (PNP)
00-01-02

PN-8800-C2NN
PROFINET 8-channel digital input (NPN & PNP)

8-channel digital output (relay)
00-01-03

PN-HH00-C0NN
PROFINET 16-channel digital input (NPN & PNP)

16-channel digital output (NPN)
00-01-04

PN-HH00-C1NN
PROFINET 16-channel digital input (NPN & PNP)

16-channel digital output (PNP)
00-01-05

PN-S000-CNNN PROFINET 32-channel digital input (NPN & PNP) 00-01-08

PN-0S00-N0NN PROFINET 32 digital outputs (NPN) 00-01-09

PN-0S00-N1NN PROFINET 32 digital outputs (PNP) 00-01-10

FS integrated-EtherCAT communication protocol digital input and output module

Product Model Product Description Order Number

EC-8800-C0NN
EtherCAT 8-channel digital input (NPN & PNP) 8-channel

digital output (NPN)
00-02-01

EC-8800-C1NN
EtherCAT 8-channel digital input (NPN & PNP) 8-channel

digital output (PNP)
00-02-02

EC-8800-C2NN
EtherCAT 8-channel digital input (NPN & PNP) 8-channel

digital output (relay)
00-02-03

EC-HH00-C0NN
EtherCAT 16-channel digital input (NPN & PNP)

16-channel digital output (NPN)
00-02-04
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EC-HH00-C1NN
EtherCAT 16-channel digital input (NPN & PNP)

16-channel digital output (PNP)
00-02-05

EC-S000-CNNN EtherCAT 32-channel digital input (NPN & PNP) 00-02-08

EC-0S00-N0NN EtherCAT 32-channel digital output (NPN) 00-02-09

EC-0S00-N1NN EtherCAT 32-channel digital output (PNP) 00-02-10

FS integrated-CC-Link communication protocol digital input and output module

Product Model Product Description Order Number

CL-8800-C0NN
CC-LINK 8-way digital input (NPN & PNP) 8-way digital

output (NPN)
00-03-01

CL-8800-C1NN
CC-LINK 8-way digital input (NPN & PNP) 8-way digital

output (PNP)
00-03-02

CL-8800-C2NN
CC-LINK 8-way digital input (NPN & PNP) 8-way digital

output (relay)
00-03-03

CL-HH00-C0NN
CC-LINK 16-channel digital input (NPN & PNP)

16-channel digital output (NPN)
00-03-04

CL-HH00-C1NN
CC-LINK 16-channel digital input (NPN & PNP)

16-channel digital output (PNP)
00-03-05

CL-S000-CNNN CC-LINK 32-channel digital input (NPN & PNP) 00-03-07

CL-0S00-N0NN CC-LINK 32-channel digital output (NPN) 00-03-08

CL-0S00-N1NN CC-LINK 32-channel digital output (PNP) 00-03-09

FS integrated-DeviceNet communication protocol digital input and output module

Product Model Product Description Order Number

DN-8800-C0NN
DEVICENET 8-channel digital input (NPN & PNP)

8-channel digital output (NPN)
00-04-01

DN-8800-C1NN
DEVICENET 8-channel digital input (NPN & PNP)

8-channel digital output (PNP)
00-04-02

DN-8800-C2NN
DEVICENET 8-channel digital input (NPN & PNP)

8-channel digital output (relay)
00-04-03
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DN-HH00-C0NN
DEVICENET 16-channel digital input (NPN & PNP)

16-channel digital output (NPN)
00-04-04

DN-HH00-C1NN
DEVICENET 16-channel digital input (NPN & PNP)

16-channel digital output (PNP)
00-04-05

DN-S000-CNNN DEVICENET 32-channel digital input (NPN & PNP) 00-04-08

DN-0S00-N0NN DEVICENET 32-channel digital output (NPN) 00-04-09

DN-0S00-N1NN DEVICENET 32-channel digital output (PNP) 00-04-10

FS integrated- CC-Link IE Field Basic communication protocol digital input and output module

Product Model Product Description Order Number

CI-8800-C0NN
CC-Link IE Field Basic 8-channel digital input (NPN &

PNP) 8-channel digital output (NPN)
00-06-01

CI-8800-C1NN
CC-Link IE Field Basic 8-channel digital input (NPN &

PNP) 8-channel digital output (PNP)
00-06-02

CI-8800-C2NN
CC-Link IE Field Basic 8-channel digital input (NPN &

PNP) 8-channel digital output (relay)
00-06-03

CI-HH00-C0NN
CC-Link IE Field Basic 16-channel digital input (NPN &

PNP) 16-channel digital output (NPN)
00-06-04

CI-HH00-C1NN
CC-Link IE Field Basic 16-channel digital input (NPN &

PNP) 16-channel digital output (PNP)
00-06-05

CI-S000-CNNN
CC-Link IE Field Basic 32-channel digital input (NPN &

PNP)
00-06-06

CI-0S00-N0NN CC-Link IE Field Basic 32-channel digital output (NPN) 00-06-07

CI-0S00-N1NN CC-Link IE Field Basic 32-channel digital output (PNP) 00-06-08

FS integrated-PROFINET communication protocol digital input and output module

Product Model Product Description Order Number

PN2-8800-C0NN
PROFINET 8-channel digital input (NPN & PNP)

8-channel digital output (NPN)
00-01-11
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PN2-8800-C1NN
PROFINET 8-channel digital input (NPN & PNP)

8-channel digital output (PNP)
00-01-12

PN2-8800-C2NN
PROFINET 8-channel digital input (NPN & PNP)

8-channel digital output (relay)
00-01-13

PN2-HH00-C0NN
PROFINET 16-channel digital input (NPN & PNP)

16-channel digital output (NPN)
00-01-14

PN2-HH00-C1NN
PROFINET 16-channel digital input (NPN & PNP)

16-channel digital output (PNP)
00-01-15

PN2-S000-CNNN PROFINET 32-channel digital input (NPN & PNP) 00-01-18

PN2-0S00-N0NN PROFINET 32 digital outputs (NPN) 00-01-19

PN2-0S00-N1NN PROFINET 32 digital outputs (PNP) 00-01-20

FS integrated-EtherNet/IP communication protocol digital input and output module

Product Model Product Description Order Number

EI2-8800-C0NN
EtherNet/IP 8-channel digital input (NPN & PNP)

8-channel digital output (NPN)
00-05-11

EI2-8800-C1NN
EtherNet/IP 8-channel digital input (NPN & PNP)

8-channel digital output (PNP)
00-05-12

EI2-8800-C2NN
EtherNet/IP 8-channel digital input (NPN & PNP)

8-channel digital output (relay)
00-05-13

EI2-HH00-C0NN
EtherNet/IP 16-channel digital input (NPN & PNP)

16-channel digital output (NPN)
00-05-14

EI2-HH00-C1NN
EtherNet/IP 16-channel digital input (NPN & PNP)

16-channel digital output (PNP)
00-05-15

EI2-S000-CNNN EtherNet/IP 32 digital inputs (NPN & PNP) 00-05-16

EI2-0S00-N0NN EtherNet/IP 32 digital outputs (NPN) 00-05-17

EI2-0S00-N1NN EtherNet/IP 32 digital outputs (PNP) 00-05-18


